Commit 4e969701 authored by Maxim Cournoyer's avatar Maxim Cournoyer Committed by Sébastien Blin
Browse files

packaging: Add jami-libqt to the jami-all package.

This makes the current 'jami-all' package the one used for the
one-click install package.

* packaging/rules/debian/rules (OCI_INSTALL_DIR): New variable.
(override_dh_auto_install): Extend rule to install the files of the
jami-libqt package.  Do not include the jami-gnome in jami-all.
* packaging/rules/debian/control (jami-all): Update description.
* packaging/rules/debian-one-click-install: Delete directory.
* packaging/rules/debian-one-click-install/jami-all.postinst: Move to ...
* packaging/rules/debian/jami-all.postinst: ... here.
* scripts/make-packaging-target.py: Remove all OCI-specific targets.
* scripts/deploy-packages.sh (package_deb) [jami-all]: Do not add
package to the apt repository.
[manual-download]: Look for the jami-all package from the main
distribution directory, not in a '_oci' suffixed version.

GitLab: jami-client-qt#263
Change-Id: I4cacf26355c767d1c77b1ce478b184023481b674
parent 7ae79f80
......@@ -37,9 +37,6 @@ RELEASE_TARBALL_FILENAME:=jami_$(RELEASE_VERSION).tar.gz
# Debian versions
DEBIAN_VERSION:=$(RELEASE_VERSION)~dfsg1-1
DEBIAN_DSC_FILENAME:=jami_$(DEBIAN_VERSION).dsc
DEBIAN_OCI_VERSION:=$(RELEASE_VERSION)~dfsg1-0
DEBIAN_OCI_DSC_FILENAME:=jami_$(DEBIAN_OCI_VERSION).dsc
DEBIAN_OCI_PKG_DIR:="packaging/rules/debian-one-click-install"
# Qt versions
QT_MAJOR:=5
......
# jami-all package for jami.net website
This source package provides a single jami-all binary package.
This binary package is the same as the mainline jami-all, apart from
the fact that it installs release keys and jami.net package repository
as trusted peers so Jami can be updated from jami.net along with
system updates.
# Notes
## Importing a new version
1- Prepare the new changelog entry mentioning the new version.
(the version on the changelog will be used to determine what to download).
Releases are available here: https://dl.jami.net/release/tarballs/
2- Run debian/rules get-orig-source
3- Import the tarball with gbp import-orig <tarball>
## tarballs-unpacked
We need those tarballs in tarballs-unpacked.
The rest should be excluded.
- msgpack-c-cpp-1.2.0.tar.gz
- opendht-281b62dfd529a226e94d0da19e01acf07871a797.tar.gz
- pjproject-2.4.5.tar.bz2
Source: jami
Section: comm
Priority: optional
Maintainer: The Jami project <jami@gnu.org>
Build-Depends: debhelper (>= 9),
autoconf,
automake,
cmake,
libtool,
autotools-dev,
# qt client
libqt-jami,
# libqt5svg5-dev,
# qml-module-qt-labs-platform,
# qml-module-qtquick-controls,
# qml-module-qtquick-controls2,
# qml-module-qtquick-dialogs,
# qml-module-qtquick-layouts,
# qml-module-qtquick-privatewidgets,
# qml-module-qtquick-shapes,
# qml-module-qtquick-templates2,
# qml-module-qtquick-window2,
# qml-module-qtquick2,
# qml-module-qtwebchannel,
# qml-module-qtwebengine | qml-module-qtwebkit,
# qtdeclarative5-dev,
# qtmultimedia5-dev,
# qtquickcontrols2-5-dev,
# qtwebengine5-dev | libqtwebkit-dev,
# both qt client and gnome client
libnm-dev,
libnotify-dev,
# gnome client
libebook1.2-dev,
libcanberra-gtk3-dev,
libclutter-gtk-1.0-dev,
libclutter-1.0-dev,
libglib2.0-dev,
libgtk-3-dev,
# qtbase5-dev,
# qttools5-dev,
# qttools5-dev-tools,
gettext,
libqrencode-dev,
libayatana-appindicator3-dev | libappindicator3-dev,
libwebkit2gtk-4.0-dev | libwebkit2gtk-3.0-dev,
# daemon
libdbus-1-dev,
libdbus-c++-dev,
libupnp-dev,
libgnutls28-dev,
libpulse-dev,
libasound2-dev,
libexpat1-dev,
libpcre3-dev,
libyaml-cpp-dev,
libboost-dev,
libxext-dev,
libxfixes-dev,
libspeex-dev,
libspeexdsp-dev,
uuid-dev,
libavcodec-dev,
libavutil-dev,
libavformat-dev,
libswscale-dev,
libavdevice-dev,
libopus-dev,
libudev-dev,
libgsm1-dev,
libjsoncpp-dev,
libnatpmp-dev,
libva-dev,
libcrypto++-dev,
libvdpau-dev,
libssl-dev,
# other
nasm,
yasm,
Standards-Version: 4.1.5
Homepage: https://jami.net
Vcs-Git: https://git.jami.net/savoirfairelinux/ring-project.git
Vcs-Browser: https://git.jami.net/savoirfairelinux/ring-project
Package: jami-all
Architecture: any
Depends: gnupg,
# libqt5sql5-sqlite,
${shlibs:Depends},
${misc:Depends}
Replaces: jami,
jami-daemon,
ring,
ring-all,
ring-daemon
Conflicts: jami,
jami-daemon,
jami-gnome,
ring,
ring-all,
ring-gnome,
ring-daemon
Description: Secure and distributed voice, video and chat platform - all in one package
Jami (jami.net) is a secure and distributed voice, video and chat communication
platform that requires no centralized server and leaves the power of privacy
in the hands of the user.
.
This package contains the GNOME desktop client and dring, the Jami daemon.
Package: ring-all
Depends: jami-all, ${misc:Depends}
Architecture: all
Description: transitional package for jami-all
This is a transitional package. It can safely be removed.
This diff is collapsed.
# We are shipping a .so, but this isn't a library package
package-name-doesnt-match-sonames
no-symbols-control-file
#!/usr/bin/make -f
# -*- makefile -*-
# Hardening
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
# Number of CPUS
NO_CPUS=$(shell nproc)
ifeq ($(NO_CPUS),0)
NO_CPUS=1
endif
# Binary package names
JAMI_ALL_IN_ONE_PKG_NAME="jami-all"
# Bundled packages from contrib
BUNDLED_PKGS=""
ifeq (raspbian_10_armhf,$(findstring raspbian_10_armhf, $(DISTRIBUTION)))
# Raspbian's yaml-cpp lib does not work properly
BUNDLED_PKGS="--enable-ffmpeg --enable-yaml-cpp"
# Add host environment variables
CMAKE_OPTIONS=-DCHOST=${HOST_ARCH} \
-DCMAKE_C_COMPILER=${HOST_ARCH}-gcc \
-DCMAKE_CXX_COMPILER=${HOST_ARCH}-g++ \
-DCMAKE_FIND_ROOT_PATH=/usr/${HOST_ARCH} \
-DPKG_CONFIG_EXECUTABLE=/usr/bin/${HOST_ARCH}-pkg-config
else
ifneq (ubuntu_21.04,$(findstring ubuntu_21.04, $(DISTRIBUTION)))
BUNDLED_PKGS="--enable-ffmpeg" # For ubuntu 21.04 it seems there is massive issues with linking for swscale
endif
endif
# Qt-related variables
QT_JAMI_PREFIX := ${QT_JAMI_PREFIX}
export PATH := $(QT_JAMI_PREFIX)/bin:${PATH}
export LD_LIBRARY_PATH := $(QT_JAMI_PREFIX)/lib:${LD_LIBRARY_PATH}
export PKG_CONFIG_PATH := $(QT_JAMI_PREFIX)/lib/pkgconfig:${PKG_CONFIG_PATH}
export CMAKE_PREFIX_PATH := $(QT_JAMI_PREFIX)/lib/cmake:${CMAKE_PREFIX_PATH}
%:
dh $@
override_dh_auto_configure:
###############################################
## Re-create tarballs from tarballs-unpacked ##
###############################################
mkdir -p daemon/contrib/tarballs
# Create tarballs
for i in $(CURDIR)/daemon/contrib/tarballs-unpacked/*; do \
projectname=`basename $$i` && \
cd $$i && tar -caf ../../tarballs/$$projectname * && \
echo "Repacked $$projectname"; \
done
###########################
## Daemon configure ##
###########################
mkdir -p daemon/contrib/native
cd daemon/contrib/native && \
../bootstrap \
--host=${HOST_ARCH} \
--disable-downloads \
--no-checksums \
--disable-ogg \
--disable-flac \
--disable-vorbis \
--disable-vorbisenc \
--disable-speex \
--disable-sndfile \
--disable-gsm \
--disable-speexdsp \
--disable-natpmp \
--enable-gnutls $(BUNDLED_PKGS) && \
make list && \
make -j$(NO_CPUS) V=1
cd daemon && \
./autogen.sh && \
./configure \
--prefix=/usr \
--disable-shared \
--host=${HOST_ARCH}
#############################
## libringclient configure ##
#############################
cd lrc && \
mkdir build && \
cd build && \
cmake \
-DRING_BUILD_DIR=$(CURDIR)/daemon/src \
-DCMAKE_INSTALL_PREFIX=/usr \
$(CMAKE_OPTIONS) \
..
############################
## gnome client configure ##
############################
cd client-gnome && \
mkdir build && \
cd build && \
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLibRingClient_PROJECT_DIR=/$(CURDIR)/lrc \
-DGSETTINGS_LOCALCOMPILE=OFF \
$(CMAKE_OPTIONS) \
..
#########################
## qt client configure ##
#########################
# needs to be done after lrc is built; see below
dh_auto_configure
override_dh_auto_build:
#######################
## Daemon build ##
#######################
make -C daemon -j$(NO_CPUS) V=1
pod2man daemon/man/dring.pod > daemon/dring.1
#########################
## libringclient build ##
#########################
make -C lrc/build -j$(NO_CPUS) V=1
########################
## gnome client build ##
########################
make -C client-gnome/build LDFLAGS="-lpthread" -j$(NO_CPUS) V=1
###################################
## qt client configure and build ##
###################################
cd client-qt && \
mkdir build && \
cd build && \
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DLRC=$(CURDIR)/lrc \
$(CMAKE_OPTIONS) \
..
make -C client-qt/build -j$(NO_CPUS) V=1
override_dh_auto_clean:
################################
## Generated contrib tarballs ##
################################
rm -rfv daemon/contrib/tarballs
#######################
## Daemon clean ##
#######################
if [ -f daemon/contrib/native/Makefile ]; then make -C daemon/contrib/native distclean; fi
rm -rfv daemon/contrib/native
rm -rfv daemon/dring.1
#########################
## libringclient clean ##
#########################
# CMake build system has no distclean target, so use clean.
if [ -f lrc/build/Makefile ]; then make -C lrc/build clean; fi
rm -rfv lrc/build
########################
## gnome client clean ##
########################
# CMake build system has no distclean target, so use clean.
if [ -f client-gnome/build/Makefile ]; then make -C client-gnome/build clean; fi
rm -rfv client-gnome/build
#####################
## qt client clean ##
#####################
# CMake build system has no distclean target, so use clean.
if [ -f client-qt/build/Makefile ]; then make -C client-qt/build clean; fi
rm -rfv client-qt/build
override_dh_clean:
# GNUTLS contains:
# ring-project/daemon/contrib/tarballs-unpacked/gnutls-3.5.10.tar.xz/gnutls-3.5.10/src/certtool-args.c.bak
# ring-project/daemon/contrib/tarballs-unpacked/gnutls-3.5.10.tar.xz/gnutls-3.5.10/doc/doxygen/Doxyfile.orig
dh_clean -X.bak -X.orig
override_dh_auto_install:
######################
## Jami AiO install ##
######################
## daemon
cd daemon && make DESTDIR=$(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME) install
rm -rfv $(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME)/usr/include
rm -rfv $(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME)/usr/lib/*.a
rm -rfv $(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME)/usr/lib/*.la
## LibRingClient
cd lrc/build && make DESTDIR=$(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME) install
rm -rfv $(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME)/usr/include
# This is a symlink, should be in -dev package
rm -v $(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME)/usr/lib/libringclient.so
# cmake files
rm -rfv $(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME)/usr/lib/cmake
## GNOME client
cd client-gnome/build && make DESTDIR=$(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME) install
rm -rfv $(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME)/usr/bin/jami
## Qt client
cd client-qt/build && \
make DESTDIR=$(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME) install
ln -sf /usr/bin/jami $(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME)/usr/bin/ring.cx
tmpdir:= $(shell mktemp -d)
workdir:= $(shell pwd)
PKD := $(abspath $(dir $(MAKEFILE_LIST)))
version_to_download := $(shell dpkg-parsechangelog -ldebian/changelog | perl -ne 'print $$1 if m{^Version:\s+(?:\d+:)?(\d.*)(?:\~dfsg.+)(?:\-\d+.*)};')
# Repacks the tarball with contrib tarballs unpacked.
get-orig-source:
# Download jami tarball
if [ -n "$$GET_ORIG_SOURCE_OVERRIDE_USCAN_TARBALL" ]; then \
mv $$GET_ORIG_SOURCE_OVERRIDE_USCAN_TARBALL ${tmpdir}; \
else \
uscan --rename --destdir=${tmpdir} --download-version ${version_to_download} ;\
fi
# Unpack jami tarball
tar -C ${tmpdir} -xf ${tmpdir}/*.tar.gz
# Remove original tarball
rm ${tmpdir}/*.tar.gz
# Unpack all of the orig tarballs into tarballs-unpacked
if [ -d "${tmpdir}/jami/" ]; then \
mv ${tmpdir}/jami/ ${tmpdir}/ring-project/; \
fi
mkdir ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked
for i in `find ${tmpdir}/ring-project/daemon/contrib/tarballs/ -name "*.tar.*"`; do \
projectname=`basename $$i` && \
mkdir ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/$$projectname && \
tar -C ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/$$projectname -xf $$i && \
echo "Unpacked $$projectname"; \
done
###################
## Exclude files ##
###################
# This does not exclude everything that we need to exclude.
# debian/copyright's File-Excluded section also excludes files.
## pjproject
rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/third_party/g7221 # non-distributable (requires a license from Polycom)
rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/third_party/ilbc # non distributable (the version included with pjproject)
rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/third_party/milenage # non distributable
rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/third_party/BaseClasses # non distributable (?)
rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/third_party/portaudio # not needed
rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/third_party/speex # not needed
rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/third_party/mp3 # not needed
rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/third_party/gsm # not needed
rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/third_party/bdsound # not needed
#rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/third_party/srtp # not needed
rm -f ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/pjmedia/src/pjmedia-audiodev/s60_g729_bitstream.h # non distributable
rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs-unpacked/pjproject-*/pjproject-*/build/vs # not needed, VisualStudio files.
# Remove all contrib tarballs
rm -rf ${tmpdir}/ring-project/daemon/contrib/tarballs
# Create the new tarball
cd ${tmpdir} && tar -czf ${workdir}/jami_${version_to_download}~dfsg1.orig.tar.gz ring-project
# Clear the temp dir
rm -rf ${tmpdir}
version=3
opts=dversionmangle=s/\~dfsg\d*$// \
https://dl.jami.net/release/tarballs/ jami_(\d\S*)\.tar\.gz
......@@ -62,6 +62,13 @@ Homepage: https://jami.net
Vcs-Git: https://git.jami.net/savoirfairelinux/ring-project.git
Vcs-Browser: https://git.jami.net/savoirfairelinux/ring-project
# The jami-all package is used as the "one-click install" package
# offered on the Jami website. The following relationships ensure
# that installing the jami-all package replaces version of the other
# individual Jami packages. This is so that users can fix any
# installation problem on their side by simply reinstalling as per the
# website instructions.
#
Package: jami-all
Architecture: any
Depends: gnupg,
......@@ -76,19 +83,20 @@ Conflicts: jami,
jami-daemon,
jami-gnome,
libqt-jami
Description: Secure and distributed voice, video and chat platform - all in one package
Jami (jami.net) is a secure and distributed voice, video and chat communication
platform that requires no centralized server and leaves the power of privacy
in the hands of the user.
.
This package contains the GNOME desktop client and dring, the Jami daemon.
Description: One-click install package for Jami
This package only exists to provide an easy installation user experience.
To install the default client, install the 'jami' package. To install
the GNOME client, install the 'jami-gnome' package.
Package: jami
Architecture: any
Depends: ${shlibs:Depends},
${misc:Depends},
jami-libclient (=${binary:Version})
jami-libclient (=${binary:Version}),
libqt-jami
Provides: jami-qt
Replaces: jami-all
Conflicts: jami-all
Description: Secure and distributed voice, video and chat platform - desktop client
Jami (jami.net) is a secure and distributed voice, video and chat communication
platform that requires no centralized server and leaves the power of privacy
......
......@@ -43,6 +43,8 @@ export LD_LIBRARY_PATH := $(QT_JAMI_PREFIX)/lib:${LD_LIBRARY_PATH}
export PKG_CONFIG_PATH := $(QT_JAMI_PREFIX)/lib/pkgconfig:${PKG_CONFIG_PATH}
export CMAKE_PREFIX_PATH := $(QT_JAMI_PREFIX)/lib/cmake:${CMAKE_PREFIX_PATH}
# Installation directories.
OCI_INSTALL_DIR = $(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME)
%:
dh $@
......@@ -225,6 +227,14 @@ override_dh_auto_install:
ln -sf /usr/bin/jami $(CURDIR)/debian/jami/usr/bin/ring.cx
## Custom Qt package for Jami (libqt-jami)
## Copy our own Qt library package content into the OCI package.
for file_name in $$(dpkg-query -L libqt-jami); do \
mkdir -p "$(OCI_INSTALL_DIR)$$(dirname $$file_name)"; \
test -d "$$file_name" && continue; \
cp "$$file_name" "$(OCI_INSTALL_DIR)$$file_name"; \
done
######################
## Jami AiO install ##
######################
......@@ -245,10 +255,6 @@ override_dh_auto_install:
# cmake files
rm -rfv $(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME)/usr/lib/cmake
## GNOME client
cd client-gnome/build && make DESTDIR=$(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME) install
rm -rfv $(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME)/usr/bin/jami
## Qt client
cd client-qt/build && \
make DESTDIR=$(CURDIR)/debian/$(JAMI_ALL_IN_ONE_PKG_NAME) install
......
......@@ -111,6 +111,7 @@ EOF
echo "## including ${package} ##"
package_name=$(dpkg -I ${package} | grep -m 1 Package: | awk '{print $2}')
package_arch=$(dpkg -I ${package} | grep -m 1 Architecture: | awk '{print $2}')
if [ ${package_arch} = "all" ]; then
# Removing to avoid the error of adding the same deb twice.
# This happens with arch all packages, which are generated in amd64 and i386.
......@@ -136,11 +137,11 @@ EOF
#######################################
## create the manual download folder ##
#######################################
if ls packages/${DISTRIBUTION}*_oci &> /dev/null; then
NAME_PATTERN=jami-all_????????.*\~dfsg*.deb
if ls packages/${DISTRIBUTION}/${NAME_PATTERN}i &> /dev/null; then
DISTRIBUTION_MANUAL_DOWNLOAD_FOLDER=$(realpath manual-download)/${DISTRIBUTION}
mkdir -p ${DISTRIBUTION_MANUAL_DOWNLOAD_FOLDER}
NAME_PATTERN=jami-all_????????.*\~dfsg*.deb
cp packages/${DISTRIBUTION}*_oci/${NAME_PATTERN} ${DISTRIBUTION_MANUAL_DOWNLOAD_FOLDER}
cp packages/${DISTRIBUTION}/${NAME_PATTERN} ${DISTRIBUTION_MANUAL_DOWNLOAD_FOLDER}
for package in ${DISTRIBUTION_MANUAL_DOWNLOAD_FOLDER}/${NAME_PATTERN} ; do
package_name=$(dpkg -I ${package} | grep -m 1 Package: | awk '{print $2}')
package_arch=$(dpkg -I ${package} | grep -m 1 Architecture: | awk '{print $2}')
......@@ -148,8 +149,6 @@ EOF
rm -f ${DISTRIBUTION_MANUAL_DOWNLOAD_FOLDER}/${package_shortname}
cp ${package} ${DISTRIBUTION_MANUAL_DOWNLOAD_FOLDER}/${package_shortname}
done
else
echo "WARNING: OCI packages directory not found"
fi
}
......
......@@ -153,47 +153,12 @@ def run_generate_all(parsed_args):
"options": DPKG_BASED_SYSTEMS_DOCKER_RUN_OPTIONS_QT,
"version": "$(DEBIAN_QT_VERSION)",
},
{
"distribution": "debian_10_oci",
"docker_image": "debian_10",
"output_file": "$(DEBIAN_OCI_DSC_FILENAME)",
"options": "-e OVERRIDE_PACKAGING_DIR=$(DEBIAN_OCI_PKG_DIR) -e QT_JAMI_PREFIX=$(QT_JAMI_PREFIX) --privileged --security-opt apparmor=docker-default",
"version": "$(DEBIAN_OCI_VERSION)",
},
{
"distribution": "debian_10_i386_oci",
"docker_image": "debian_10_i386",
"output_file": "$(DEBIAN_OCI_DSC_FILENAME)",
"options": "-e OVERRIDE_PACKAGING_DIR=$(DEBIAN_OCI_PKG_DIR) --privileged --security-opt apparmor=docker-default",
"version": "$(DEBIAN_OCI_VERSION)",
},
{
"distribution": "debian_10_armhf_oci",
"docker_image": "debian_10_armhf",
"output_file": "$(DEBIAN_DSC_FILENAME)",
"options": "-e OVERRIDE_PACKAGING_DIR=$(DEBIAN_OCI_PKG_DIR) --privileged --security-opt apparmor=docker-default",
"version": "$(DEBIAN_OCI_VERSION)"
},
{
"distribution": "debian_10_arm64_oci",
"docker_image": "debian_10_arm64",
"output_file": "$(DEBIAN_DSC_FILENAME)",
"options": "-e OVERRIDE_PACKAGING_DIR=$(DEBIAN_OCI_PKG_DIR) --privileged --security-opt apparmor=docker-default",
"version": "$(DEBIAN_OCI_VERSION)"
},
# Raspbian
{
"distribution": "raspbian_10_armhf",
"output_file": "$(DEBIAN_DSC_FILENAME)",
"options": "--privileged --security-opt apparmor=docker-default",
},
{
"distribution": "raspbian_10_armhf_oci",
"docker_image": "raspbian_10_armhf",
"output_file": "$(DEBIAN_DSC_FILENAME)",
"options": "-e OVERRIDE_PACKAGING_DIR=$(DEBIAN_OCI_PKG_DIR) --privileged --security-opt apparmor=docker-default",
"version": "$(DEBIAN_OCI_VERSION)",
},
# Ubuntu
{