Commit 837951a5 authored by Tristan Matthews's avatar Tristan Matthews

* #6082: fixes make check by adding libcrypto libs to test dependencies

parent 3935e463
......@@ -173,6 +173,9 @@ dnl AC_SUBST(UUID_LIBS)
UUID_MIN_VERSION=1.0
PKG_CHECK_MODULES(UUID, uuid >= ${UUID_MIN_VERSION}, HAVE_UUID=true, HAVE_UUID=false);
LIBCRYPTO_MIN_VERSION=1.0
PKG_CHECK_MODULES(LIBCRYPTO, libcrypto >= ${LIBCRYPTO_MIN_VERSION}, HAVE_LIBCRYPTO=true, HAVE_LIBCRYPTO=false);
dnl Check for alsa development package - name: libasound2-dev
ALSA_MIN_VERSION=1.0
PKG_CHECK_MODULES(ALSA, alsa >= ${ALSA_MIN_VERSION},, AC_MSG_ERROR([Missing alsa development package: libasound2-dev or alsa-lib-devel]))
......
......@@ -3,7 +3,7 @@ include ../globals.mak
check_PROGRAMS = test
test_CXXFLAGS = $(CPPUNIT_CFLAGS)
test_LDADD = $(LLIBS)
test_LDADD = $(LLIBS) @LIBCRYPTO_LIBS@
test_SOURCES = \
main.cpp \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment