Commit cffdc750 authored by Alexandre Lision's avatar Alexandre Lision Committed by gerrit2

configure: check alsa/pulse support only for linux

- allows to build OSX without having to pass --without-alsa --without-pulse.
- update doc accordingly

Change-Id: I5b26c58d1954ef2d2613724c24fba750333ae890
parent abe05dbd
......@@ -106,7 +106,7 @@ make -j
# Then the daemon
cd ../../
./autogen.sh
./configure --without-alsa --without-pulse --without-dbus --prefix=<install_path>
./configure --without-dbus --prefix=<install_path>
make
If you want to link against libringclient and native client easiest way is to
......
......@@ -113,6 +113,7 @@ AS_IF([test "$SYS" = linux],[
AC_MSG_RESULT([no])
])
])
AM_CONDITIONAL(HAVE_ANDROID, test "${HAVE_ANDROID}" = "1")
dnl override platform specific check for dependent libraries
......@@ -264,7 +265,7 @@ if test "${HAVE_ANDROID}" = "1"; then
fi
AM_CONDITIONAL([BUILD_OPENSL], test "x$have_opensl" = "xyes")
if test "${SYS}" != "mingw32"; then
if test "${SYS}" = "linux"; then
dnl Check for alsa development package - name: libasound2-dev
ALSA_MIN_VERSION=1.0
AC_ARG_WITH([alsa],
......@@ -280,7 +281,7 @@ fi
AM_CONDITIONAL(BUILD_ALSA, test "x$with_alsa" = "xyes")
if test "${SYS}" != "mingw32"; then
if test "${SYS}" = "linux"; then
dnl Check for pulseaudio development package - name: libpulse-dev
LIBPULSE_MIN_VERSION=0.9.15
AC_ARG_WITH([pulse],
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment