Commit 5e8170bb authored by aviau's avatar aviau

Packaging: distroX -> distro_X

This changes the way we name distros in order to be compatible with the
current repository layout

Change-Id: Ib21bb21c943183ed0f4c47efea9432b54e0a5b79
Tuleap: #872
parent 9415c75a
...@@ -71,16 +71,16 @@ $(RELEASE_TARBALL_FILENAME): ...@@ -71,16 +71,16 @@ $(RELEASE_TARBALL_FILENAME):
####################### #######################
.PHONY: package-all .PHONY: package-all
package-all: package-debian8 \ package-all: package-debian_8 \
package-debian8_i386 \ package-debian_8_i386 \
package-debian9 \ package-debian_9 \
package-debian9_i386 \ package-debian_9_i386 \
package-ubuntu14.04 \ package-ubuntu_14.04 \
package-ubuntu14.04_i386 \ package-ubuntu_14.04_i386 \
package-ubuntu15.10 \ package-ubuntu_15.10 \
package-ubuntu15.10_i386 \ package-ubuntu_15.10_i386 \
package-ubuntu16.04 \ package-ubuntu_16.04 \
package-ubuntu16.04_i386 package-ubuntu_16.04_i386
# Append the output of make-packaging-target to this Makefile # Append the output of make-packaging-target to this Makefile
# see Makefile.packaging.distro_targets # see Makefile.packaging.distro_targets
......
...@@ -45,8 +45,8 @@ dch --create --package ring --newversion ${DEBIAN_VERSION} "Automatic nightly re ...@@ -45,8 +45,8 @@ dch --create --package ring --newversion ${DEBIAN_VERSION} "Automatic nightly re
dch --release --distribution "unstable" debian/changelog dch --release --distribution "unstable" debian/changelog
# create orig tarball # create orig tarball
# mk-origtargz isn't in ubuntu14.04 # mk-origtargz isn't in ubuntu_14.04
if [ "${DISTRIBUTION}" = "ubuntu14.04" ] || [ "${DISTRIBUTION}" = "ubuntu14.04_i386" ]; then if [ "${DISTRIBUTION}" = "ubuntu_14.04" ] || [ "${DISTRIBUTION}" = "ubuntu_14.04_i386" ]; then
mv ${RELEASE_TARBALL_FILENAME} ../ring_${DEBIAN_VERSION}.orig.tar.gz mv ${RELEASE_TARBALL_FILENAME} ../ring_${DEBIAN_VERSION}.orig.tar.gz
else else
mk-origtargz ${RELEASE_TARBALL_FILENAME} mk-origtargz ${RELEASE_TARBALL_FILENAME}
......
...@@ -89,44 +89,44 @@ def run_generate_all(parsed_args): ...@@ -89,44 +89,44 @@ def run_generate_all(parsed_args):
targets = [ targets = [
# Debian # Debian
{ {
"distribution": "debian8", "distribution": "debian_8",
"debian_packaging_override": "", "debian_packaging_override": "",
}, },
{ {
"distribution": "debian8_i386", "distribution": "debian_8_i386",
"debian_packaging_override": "", "debian_packaging_override": "",
}, },
{ {
"distribution": "debian9", "distribution": "debian_9",
"debian_packaging_override": "", "debian_packaging_override": "",
}, },
{ {
"distribution": "debian9_i386", "distribution": "debian_9_i386",
"debian_packaging_override": "", "debian_packaging_override": "",
}, },
# Ubuntu # Ubuntu
{ {
"distribution": "ubuntu14.04", "distribution": "ubuntu_14.04",
"debian_packaging_override": "", "debian_packaging_override": "",
}, },
{ {
"distribution": "ubuntu14.04_i386", "distribution": "ubuntu_14.04_i386",
"debian_packaging_override": "", "debian_packaging_override": "",
}, },
{ {
"distribution": "ubuntu15.10", "distribution": "ubuntu_15.10",
"debian_packaging_override": "", "debian_packaging_override": "",
}, },
{ {
"distribution": "ubuntu15.10_i386", "distribution": "ubuntu_15.10_i386",
"debian_packaging_override": "", "debian_packaging_override": "",
}, },
{ {
"distribution": "ubuntu16.04", "distribution": "ubuntu_16.04",
"debian_packaging_override": "", "debian_packaging_override": "",
}, },
{ {
"distribution": "ubuntu16.04_i386", "distribution": "ubuntu_16.04_i386",
"debian_packaging_override": "", "debian_packaging_override": "",
}, },
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment