Commit 9a6e4ae6 authored by Stepan Salenikovich's avatar Stepan Salenikovich

make-ring: add webkitgtk as dependency

We also run apt-get with --ignore-missing option so that it doesn't
fail in case a dependency is missing. We use this to require both
libwebkit2gtk-4.0-dev and libwebkit2gtk-3.0-dev for ubuntu since
14.04 only has the latter.
Reviewed-by: default avatarAlexandre Viau <alexandre@alexandreviau.net>
Change-Id: I0b7428cd4ad2c7e2a10634aff14fe14e6fccc253
parent 0070c098
......@@ -34,7 +34,7 @@ SUSE_BASED_DISTROS = [
APT_INSTALL_SCRIPT = [
'apt-get update',
'apt-get install -y %(packages)s'
'apt-get install -y %(packages)s --ignore-missing'
]
BREW_INSTALL_SCRIPT = [
......@@ -71,7 +71,7 @@ OPENSUSE_DEPENDENCIES = [
'libQt5Core-devel', 'libQt5DBus-devel', 'libqt5-linguist-devel',
# gnome client
'gtk3-devel', 'clutter-gtk-devel', 'qrencode-devel', 'evolution-data-server-devel',
'gettext-tools', 'libnotify-devel', 'libappindicator3-devel',
'gettext-tools', 'libnotify-devel', 'libappindicator3-devel', 'webkit2gtk3-devel'
]
MINGW64_FEDORA_DEPENDENCIES = [
......@@ -98,7 +98,8 @@ FEDORA_DEPENDENCIES = [
'uuid-devel', 'gnutls-devel', 'nettle-devel', 'opus-devel', 'speexdsp-devel',
'yaml-cpp-devel', 'qt5-qtbase-devel', 'swig', 'qrencode-devel', 'jsoncpp-devel',
'gtk3-devel', 'clutter-devel', 'clutter-gtk-devel', 'evolution-data-server-devel',
'libnotify-devel', 'libappindicator-gtk3-devel', 'patch', 'libva-devel'
'libnotify-devel', 'libappindicator-gtk3-devel', 'patch', 'libva-devel',
'webkitgtk4-devel'
]
UBUNTU_DEPENDENCIES = [
......@@ -112,7 +113,8 @@ UBUNTU_DEPENDENCIES = [
'libsndfile1-dev', 'libspeex-dev', 'libspeexdsp-dev', 'libswscale-dev', 'libtool',
'libudev-dev', 'libupnp-dev', 'libyaml-cpp-dev', 'qtbase5-dev', 'sip-tester', 'swig',
'uuid-dev', 'yasm', 'libqrencode-dev', 'libjsoncpp-dev', 'libappindicator3-dev',
'libva-dev'
'libva-dev',
'libwebkit2gtk-4.0-dev', 'libwebkit2gtk-3.0-dev' # we prefer 4.0, but 3.0 will work, we use --ignore-missing so apt-get doesn't fail
]
DEBIAN_DEPENDENCIES = [
......@@ -126,7 +128,7 @@ DEBIAN_DEPENDENCIES = [
'libsndfile1-dev', 'libspeex-dev', 'libspeexdsp-dev', 'libswscale-dev', 'libtool',
'libudev-dev', 'libupnp-dev', 'libyaml-cpp-dev', 'qtbase5-dev', 'sip-tester', 'swig',
'uuid-dev', 'yasm', 'libqrencode-dev', 'libjsoncpp-dev', 'libappindicator3-dev',
'libva-dev'
'libva-dev', 'libwebkit2gtk-4.0-dev'
]
ARCH_LINUX_DEPENDENCIES = [
......@@ -135,7 +137,7 @@ ARCH_LINUX_DEPENDENCIES = [
'expat', 'gsm', 'gtk3', 'jack', 'libnotify', 'opus', 'pcre', 'libpulse', 'libsamplerate',
'libsndfile', 'speex', 'speexdsp', 'libtool', 'libupnp', 'yaml-cpp', 'qt5-base',
'swig', 'yasm', 'qrencode', 'evolution-data-server', 'make', 'patch', 'pkg-config',
'automake', 'libva'
'automake', 'libva', 'webkitgtk'
]
OSX_DEPENDENCIES = [
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment