Commit 9c5c4ad2 authored by aviau's avatar aviau

Debian packaging fixes

This imports some of the changes made in the official Debian packaging
repository: https://anonscm.debian.org/cgit/pkg-voip/ring.git

- Don't run containers in interactive mode, which would require a TTY

- Build LRC with Debug symbols

- Build with V=1 to allow parsing logs

- Reorganize dependencies

- Try fetch-all three times before giving up

- Removed ubuntu15.04 references

Tuleap: #858
Change-Id: If0a81b15230a31d120982e113e695443262568e3
parent f89d706d
...@@ -54,7 +54,7 @@ $(RELEASE_TARBALL_FILENAME): ...@@ -54,7 +54,7 @@ $(RELEASE_TARBALL_FILENAME):
mkdir -p daemon/contrib/native mkdir -p daemon/contrib/native
cd daemon/contrib/native && \ cd daemon/contrib/native && \
../bootstrap && \ ../bootstrap && \
make fetch-all make fetch-all || make fetch-all || make fetch-all
rm -rf daemon/contrib/native rm -rf daemon/contrib/native
cd $(TMPDIR) && \ cd $(TMPDIR) && \
......
client-gnome @ f762d388
Subproject commit 884c37c0d1ceb17d0146f174d014f56092373593 Subproject commit f762d3883db21d53980b6ba66a9ebd034cda6959
daemon @ eb67d2fc
Subproject commit 150035a81912cc8109331c684d8ad5be6b343e8f Subproject commit eb67d2fc61853eb3b29ed7b8dd70553f18ac7f01
...@@ -5,21 +5,53 @@ RUN apt-get update && \ ...@@ -5,21 +5,53 @@ RUN apt-get update && \
# Speed up mk-build-deps # Speed up mk-build-deps
RUN apt-get update && \ RUN apt-get update && \
apt-get install -y autoconf automake cmake libtool libdbus-1-dev \ apt-get install -y -o Acquire::Retires=10 \
libdbus-c++-dev libupnp-dev \ autoconf \
libebook1.2-dev libclutter-gtk-1.0-dev \ automake \
libclutter-1.0-dev libglib2.0-dev libgtk-3-dev \ autopoint \
libnotify-dev qtbase5-dev qttools5-dev \ cmake \
qttools5-dev-tools yasm unbound-anchor git-core \ libtool \
autotools-dev gnome-icon-theme-symbolic gettext \ libdbus-1-dev \
libpulse-dev libsamplerate0-dev libasound2-dev \ libdbus-c++-dev \
libexpat1-dev libpcre3-dev libyaml-cpp-dev \ libupnp-dev \
libboost-dev libsndfile1-dev libsrtp-dev \ libebook1.2-dev \
libxext-dev libxfixes-dev autopoint libspeex-dev \ libclutter-gtk-1.0-dev \
libspeexdsp-dev chrpath uuid-dev libavcodec-dev \ libclutter-1.0-dev \
libavutil-dev libavformat-dev libswscale-dev \ libglib2.0-dev \
libavdevice-dev libopus-dev libudev-dev libticonv-dev \ libgtk-3-dev \
libgsm1-dev libjsoncpp-dev libqrencode-dev libnotify-dev \
qtbase5-dev \
qttools5-dev \
qttools5-dev-tools \
yasm \
autotools-dev \
gettext \
libpulse-dev \
libsamplerate0-dev \
libasound2-dev \
libexpat1-dev \
libpcre3-dev \
libyaml-cpp-dev \
libboost-dev \
libsndfile1-dev \
libsrtp-dev \
libxext-dev \
libxfixes-dev \
libspeex-dev \
libspeexdsp-dev \
uuid-dev \
libavcodec-dev \
libavutil-dev \
libavformat-dev \
libswscale-dev \
libavdevice-dev \
libopus-dev \
libudev-dev \
libgsm1-dev \
libjsoncpp-dev \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev
ADD scripts/build-package-debian.sh /opt/build-package-debian.sh ADD scripts/build-package-debian.sh /opt/build-package-debian.sh
......
...@@ -5,21 +5,53 @@ RUN apt-get update && \ ...@@ -5,21 +5,53 @@ RUN apt-get update && \
# Speed up mk-build-deps # Speed up mk-build-deps
RUN apt-get update && \ RUN apt-get update && \
apt-get install -y autoconf automake cmake libtool libdbus-1-dev \ apt-get install -y -o Acquire::Retires=10 \
libdbus-c++-dev libupnp-dev \ autoconf \
libebook1.2-dev libclutter-gtk-1.0-dev \ automake \
libclutter-1.0-dev libglib2.0-dev libgtk-3-dev \ autopoint \
libnotify-dev qtbase5-dev qttools5-dev \ cmake \
qttools5-dev-tools yasm unbound-anchor git-core \ libtool \
autotools-dev gnome-icon-theme-symbolic gettext \ libdbus-1-dev \
libpulse-dev libsamplerate0-dev libasound2-dev \ libdbus-c++-dev \
libexpat1-dev libpcre3-dev libyaml-cpp-dev \ libupnp-dev \
libboost-dev libsndfile1-dev libsrtp-dev \ libebook1.2-dev \
libxext-dev libxfixes-dev autopoint libspeex-dev \ libclutter-gtk-1.0-dev \
libspeexdsp-dev chrpath uuid-dev libavcodec-dev \ libclutter-1.0-dev \
libavutil-dev libavformat-dev libswscale-dev \ libglib2.0-dev \
libavdevice-dev libopus-dev libudev-dev libticonv-dev \ libgtk-3-dev \
libgsm1-dev libjsoncpp-dev libqrencode-dev libnotify-dev \
qtbase5-dev \
qttools5-dev \
qttools5-dev-tools \
yasm \
autotools-dev \
gettext \
libpulse-dev \
libsamplerate0-dev \
libasound2-dev \
libexpat1-dev \
libpcre3-dev \
libyaml-cpp-dev \
libboost-dev \
libsndfile1-dev \
libsrtp-dev \
libxext-dev \
libxfixes-dev \
libspeex-dev \
libspeexdsp-dev \
uuid-dev \
libavcodec-dev \
libavutil-dev \
libavformat-dev
libswscale-dev \
libavdevice-dev \
libopus-dev \
libudev-dev \
libgsm1-dev \
libjsoncpp-dev \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev
ADD scripts/build-package-debian.sh /opt/build-package-debian.sh ADD scripts/build-package-debian.sh /opt/build-package-debian.sh
......
...@@ -5,21 +5,53 @@ RUN apt-get update && \ ...@@ -5,21 +5,53 @@ RUN apt-get update && \
# Speed up mk-build-deps # Speed up mk-build-deps
RUN apt-get update && \ RUN apt-get update && \
apt-get install -y autoconf automake cmake libtool libdbus-1-dev \ apt-get install -y -o Acquire::Retires=10 \
libdbus-c++-dev libupnp-dev libgnutls28-dev \ autoconf \
libebook1.2-dev libclutter-gtk-1.0-dev \ automake \
libclutter-1.0-dev libglib2.0-dev libgtk-3-dev \ autopoint \
libnotify-dev qtbase5-dev qttools5-dev \ cmake \
qttools5-dev-tools yasm unbound-anchor git-core \ libtool \
autotools-dev gnome-icon-theme-symbolic gettext \ libdbus-1-dev \
libpulse-dev libsamplerate0-dev libasound2-dev \ libdbus-c++-dev \
libexpat1-dev libpcre3-dev libyaml-cpp-dev \ libupnp-dev \
libboost-dev libsndfile1-dev libsrtp-dev \ libebook1.2-dev \
libxext-dev libxfixes-dev autopoint libspeex-dev \ libclutter-gtk-1.0-dev \
libspeexdsp-dev chrpath uuid-dev libavcodec-dev \ libclutter-1.0-dev \
libavutil-dev libavformat-dev libswscale-dev \ libglib2.0-dev \
libavdevice-dev libopus-dev libudev-dev libticonv-dev \ libgtk-3-dev \
libgsm1-dev libjsoncpp-dev libqrencode-dev libnotify-dev \
qtbase5-dev \
qttools5-dev \
qttools5-dev-tools \
yasm \
autotools-dev \
gettext \
libpulse-dev \
libsamplerate0-dev \
libasound2-dev \
libexpat1-dev \
libpcre3-dev \
libyaml-cpp-dev \
libboost-dev \
libsndfile1-dev \
libsrtp-dev \
libxext-dev \
libxfixes-dev \
libspeex-dev \
libspeexdsp-dev \
uuid-dev \
libavcodec-dev \
libavutil-dev \
libavformat-dev \
libswscale-dev \
libavdevice-dev \
libopus-dev \
libudev-dev \
libgsm1-dev \
libjsoncpp-dev \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev
ADD scripts/build-package-debian.sh /opt/build-package-debian.sh ADD scripts/build-package-debian.sh /opt/build-package-debian.sh
......
...@@ -5,21 +5,53 @@ RUN apt-get update && \ ...@@ -5,21 +5,53 @@ RUN apt-get update && \
# Speed up mk-build-deps # Speed up mk-build-deps
RUN apt-get update && \ RUN apt-get update && \
apt-get install -y autoconf automake cmake libtool libdbus-1-dev \ apt-get install -y -o Acquire::Retires=10 \
libdbus-c++-dev libupnp-dev libgnutls28-dev \ autoconf \
libebook1.2-dev libclutter-gtk-1.0-dev \ automake \
libclutter-1.0-dev libglib2.0-dev libgtk-3-dev \ autopoint \
libnotify-dev qtbase5-dev qttools5-dev \ cmake \
qttools5-dev-tools yasm unbound-anchor git-core \ libtool \
autotools-dev gnome-icon-theme-symbolic gettext \ libdbus-1-dev \
libpulse-dev libsamplerate0-dev libasound2-dev \ libdbus-c++-dev \
libexpat1-dev libpcre3-dev libyaml-cpp-dev \ libupnp-dev \
libboost-dev libsndfile1-dev libsrtp-dev \ libebook1.2-dev \
libxext-dev libxfixes-dev autopoint libspeex-dev \ libclutter-gtk-1.0-dev \
libspeexdsp-dev chrpath uuid-dev libavcodec-dev \ libclutter-1.0-dev \
libavutil-dev libavformat-dev libswscale-dev \ libglib2.0-dev \
libavdevice-dev libopus-dev libudev-dev libticonv-dev \ libgtk-3-dev \
libgsm1-dev libjsoncpp-dev libqrencode-dev libnotify-dev \
qtbase5-dev \
qttools5-dev \
qttools5-dev-tools \
yasm \
autotools-dev \
gettext \
libpulse-dev \
libsamplerate0-dev \
libasound2-dev \
libexpat1-dev \
libpcre3-dev \
libyaml-cpp-dev \
libboost-dev \
libsndfile1-dev \
libsrtp-dev \
libxext-dev \
libxfixes-dev \
libspeex-dev \
libspeexdsp-dev \
uuid-dev \
libavcodec-dev \
libavutil-dev \
libavformat-dev \
libswscale-dev \
libavdevice-dev \
libopus-dev \
libudev-dev \
libgsm1-dev \
libjsoncpp-dev \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev
ADD scripts/build-package-debian.sh /opt/build-package-debian.sh ADD scripts/build-package-debian.sh /opt/build-package-debian.sh
......
...@@ -5,21 +5,54 @@ RUN apt-get update && \ ...@@ -5,21 +5,54 @@ RUN apt-get update && \
# Speed up mk-build-deps # Speed up mk-build-deps
RUN apt-get update && \ RUN apt-get update && \
apt-get install -y autoconf automake cmake libtool libdbus-1-dev \ apt-get install -y -o Acquire::Retires=10 \
libdbus-c++-dev libupnp-dev \ autoconf \
libebook1.2-dev libclutter-gtk-1.0-dev \ automake \
libclutter-1.0-dev libglib2.0-dev libgtk-3-dev \ autopoint \
libnotify-dev qtbase5-dev qttools5-dev \ cmake \
qttools5-dev-tools yasm unbound-anchor git-core \ libtool \
autotools-dev gnome-icon-theme-symbolic gettext \ libdbus-1-dev \
libpulse-dev libsamplerate0-dev libasound2-dev \ libdbus-c++-dev \
libexpat1-dev libpcre3-dev libyaml-cpp-dev \ libupnp-dev \
libboost-dev libsndfile1-dev libsrtp-dev \ libgnutls28-dev \
libxext-dev libxfixes-dev autopoint libspeex-dev \ libebook1.2-dev \
libspeexdsp-dev chrpath uuid-dev libavcodec-dev \ libclutter-gtk-1.0-dev \
libavutil-dev libavformat-dev libswscale-dev \ libclutter-1.0-dev \
libavdevice-dev libopus-dev libudev-dev libticonv-dev \ libglib2.0-dev \
libgsm1-dev libjsoncpp-dev libqrencode-dev libgtk-3-dev \
libnotify-dev \
qtbase5-dev \
qttools5-dev \
qttools5-dev-tools \
yasm \
autotools-dev \
gettext \
libpulse-dev \
libsamplerate0-dev \
libasound2-dev \
libexpat1-dev \
libpcre3-dev \
libyaml-cpp-dev \
libboost-dev \
libsndfile1-dev \
libsrtp-dev \
libxext-dev \
libxfixes-dev \
libspeex-dev \
libspeexdsp-dev \
uuid-dev \
libavcodec-dev \
libavutil-dev \
libavformat-dev \
libswscale-dev \
libavdevice-dev \
libopus-dev \
libudev-dev \
libgsm1-dev \
libjsoncpp-dev \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev
ADD scripts/build-package-debian.sh /opt/build-package-debian.sh ADD scripts/build-package-debian.sh /opt/build-package-debian.sh
......
...@@ -5,21 +5,54 @@ RUN apt-get update && \ ...@@ -5,21 +5,54 @@ RUN apt-get update && \
# Speed up mk-build-deps # Speed up mk-build-deps
RUN apt-get update && \ RUN apt-get update && \
apt-get install -y autoconf automake cmake libtool libdbus-1-dev \ apt-get install -y -o Acquire::Retires=10 \
libdbus-c++-dev libupnp-dev \ autoconf \
libebook1.2-dev libclutter-gtk-1.0-dev \ automake \
libclutter-1.0-dev libglib2.0-dev libgtk-3-dev \ autopoint \
libnotify-dev qtbase5-dev qttools5-dev \ cmake \
qttools5-dev-tools yasm unbound-anchor git-core \ libtool \
autotools-dev gnome-icon-theme-symbolic gettext \ libdbus-1-dev \
libpulse-dev libsamplerate0-dev libasound2-dev \ libdbus-c++-dev \
libexpat1-dev libpcre3-dev libyaml-cpp-dev \ libupnp-dev \
libboost-dev libsndfile1-dev libsrtp-dev \ libgnutls28-dev \
libxext-dev libxfixes-dev autopoint libspeex-dev \ libebook1.2-dev \
libspeexdsp-dev chrpath uuid-dev libavcodec-dev \ libclutter-gtk-1.0-dev \
libavutil-dev libavformat-dev libswscale-dev \ libclutter-1.0-dev \
libavdevice-dev libopus-dev libudev-dev libticonv-dev \ libglib2.0-dev \
libgsm1-dev libjsoncpp-dev libqrencode-dev libgtk-3-dev \
libnotify-dev \
qtbase5-dev \
qttools5-dev \
qttools5-dev-tools \
yasm \
autotools-dev \
gettext \
libpulse-dev \
libsamplerate0-dev \
libasound2-dev \
libexpat1-dev \
libpcre3-dev \
libyaml-cpp-dev \
libboost-dev \
libsndfile1-dev \
libsrtp-dev \
libxext-dev \
libxfixes-dev \
libspeex-dev \
libspeexdsp-dev \
uuid-dev \
libavcodec-dev \
libavutil-dev \
libavformat-dev \
libswscale-dev \
libavdevice-dev \
libopus-dev \
libudev-dev \
libgsm1-dev \
libjsoncpp-dev \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev
ADD scripts/build-package-debian.sh /opt/build-package-debian.sh ADD scripts/build-package-debian.sh /opt/build-package-debian.sh
......
...@@ -5,21 +5,54 @@ RUN apt-get update && \ ...@@ -5,21 +5,54 @@ RUN apt-get update && \
# Speed up mk-build-deps # Speed up mk-build-deps
RUN apt-get update && \ RUN apt-get update && \
apt-get install -y autoconf automake cmake libtool libdbus-1-dev \ apt-get install -y -o Acquire::Retires=10 \
libdbus-c++-dev libupnp-dev \ autoconf \
libebook1.2-dev libclutter-gtk-1.0-dev \ automake \
libclutter-1.0-dev libglib2.0-dev libgtk-3-dev \ autopoint \
libnotify-dev qtbase5-dev qttools5-dev \ cmake \
qttools5-dev-tools yasm unbound-anchor git-core \ libtool \
autotools-dev gnome-icon-theme-symbolic gettext \ libdbus-1-dev \
libpulse-dev libsamplerate0-dev libasound2-dev \ libdbus-c++-dev \
libexpat1-dev libpcre3-dev libyaml-cpp-dev \ libupnp-dev \
libboost-dev libsndfile1-dev libsrtp-dev \ libgnutls28-dev \
libxext-dev libxfixes-dev autopoint libspeex-dev \ libebook1.2-dev \
libspeexdsp-dev chrpath uuid-dev libavcodec-dev \ libclutter-gtk-1.0-dev \
libavutil-dev libavformat-dev libswscale-dev \ libclutter-1.0-dev \
libavdevice-dev libopus-dev libudev-dev libticonv-dev \ libglib2.0-dev \
libgsm1-dev libjsoncpp-dev libqrencode-dev libgtk-3-dev \
libnotify-dev \
qtbase5-dev \
qttools5-dev \
qttools5-dev-tools \
yasm \
autotools-dev \
gettext \
libpulse-dev \
libsamplerate0-dev \
libasound2-dev \
libexpat1-dev \
libpcre3-dev \
libyaml-cpp-dev \
libboost-dev \
libsndfile1-dev \
libsrtp-dev \
libxext-dev \
libxfixes-dev \
libspeex-dev \
libspeexdsp-dev \
uuid-dev \
libavcodec-dev \
libavutil-dev \
libavformat-dev \
libswscale-dev \
libavdevice-dev \
libopus-dev \
libudev-dev \
libgsm1-dev \
libjsoncpp-dev \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev
ADD scripts/build-package-debian.sh /opt/build-package-debian.sh ADD scripts/build-package-debian.sh /opt/build-package-debian.sh
......
...@@ -5,21 +5,54 @@ RUN apt-get update && \ ...@@ -5,21 +5,54 @@ RUN apt-get update && \
# Speed up mk-build-deps # Speed up mk-build-deps
RUN apt-get update && \ RUN apt-get update && \
apt-get install -y autoconf automake cmake libtool libdbus-1-dev \ apt-get install -y -o Acquire::Retires=10 \
libdbus-c++-dev libupnp-dev \ autoconf \
libebook1.2-dev libclutter-gtk-1.0-dev \ automake \
libclutter-1.0-dev libglib2.0-dev libgtk-3-dev \ autopoint \
libnotify-dev qtbase5-dev qttools5-dev \ cmake \
qttools5-dev-tools yasm unbound-anchor git-core \ libtool \
autotools-dev gnome-icon-theme-symbolic gettext \ libdbus-1-dev \
libpulse-dev libsamplerate0-dev libasound2-dev \ libdbus-c++-dev \
libexpat1-dev libpcre3-dev libyaml-cpp-dev \ libupnp-dev \
libboost-dev libsndfile1-dev libsrtp-dev \ libgnutls28-dev \
libxext-dev libxfixes-dev autopoint libspeex-dev \ libebook1.2-dev \
libspeexdsp-dev chrpath uuid-dev libavcodec-dev \ libclutter-gtk-1.0-dev \
libavutil-dev libavformat-dev libswscale-dev \ libclutter-1.0-dev \
libavdevice-dev libopus-dev libudev-dev libticonv-dev \ libglib2.0-dev \
libgsm1-dev libjsoncpp-dev libqrencode-dev libgtk-3-dev \
libnotify-dev \
qtbase5-dev \
qttools5-dev \
qttools5-dev-tools \
yasm \
autotools-dev \
gettext \
libpulse-dev \
libsamplerate0-dev \
libasound2-dev \
libexpat1-dev \
libpcre3-dev \
libyaml-cpp-dev \
libboost-dev \
libsndfile1-dev \
libsrtp-dev \
libxext-dev \
libxfixes-dev \
libspeex-dev \
libspeexdsp-dev \
uuid-dev \
libavcodec-dev \
libavutil-dev \
libavformat-dev \
libswscale-dev \
libavdevice-dev \
libopus-dev \
libudev-dev \
libgsm1-dev \
libjsoncpp-dev \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev
ADD scripts/build-package-debian.sh /opt/build-package-debian.sh ADD scripts/build-package-debian.sh /opt/build-package-debian.sh
......
...@@ -5,21 +5,54 @@ RUN apt-get update && \ ...@@ -5,21 +5,54 @@ RUN apt-get update && \
# Speed up mk-build-deps # Speed up mk-build-deps
RUN apt-get update && \ RUN apt-get update && \
apt-get install -y autoconf automake cmake libtool libdbus-1-dev \ apt-get install -y -o Acquire::Retires=10 \
libdbus-c++-dev libupnp-dev libgnutls28-dev \ autoconf \
libebook1.2-dev libclutter-gtk-1.0-dev \ automake \
libclutter-1.0-dev libglib2.0-dev libgtk-3-dev \ autopoint \
libnotify-dev qtbase5-dev qttools5-dev \ cmake \
qttools5-dev-tools yasm unbound-anchor git-core \ libtool \
autotools-dev gnome-icon-theme-symbolic gettext \ libdbus-1-dev \
libpulse-dev libsamplerate0-dev libasound2-dev \ libdbus-c++-dev \
libexpat1-dev libpcre3-dev libyaml-cpp-dev \ libupnp-dev \
libboost-dev libsndfile1-dev libsrtp-dev \ libgnutls28-dev \
libxext-dev libxfixes-dev autopoint libspeex-dev \ libebook1.2-dev \
libspeexdsp-dev chrpath uuid-dev libavcodec-dev \ libclutter-gtk-1.0-dev \
libavutil-dev libavformat-dev libswscale-dev \ libclutter-1.0-dev \
libavdevice-dev libopus-dev libudev-dev libticonv-dev \ libglib2.0-dev \
libgsm1-dev libjsoncpp-dev libqrencode-dev libgtk-3-dev \
libnotify-dev \
qtbase5-dev \
qttools5-dev \
qttools5-dev-tools \
yasm \
autotools-dev \
gettext \
libpulse-dev \
libsamplerate0-dev \
libasound2-dev \
libexpat1-dev \
libpcre3-dev \
libyaml-cpp-dev \
libboost-dev \
libsndfile1-dev \
libsrtp-dev \
libxext-dev \
libxfixes-dev \
libspeex-dev \
libspeexdsp-dev \
uuid-dev \
libavcodec-dev \
libavutil-dev \
libavformat-dev \
libswscale-dev \
libavdevice-dev \
libopus-dev \
libudev-dev \
libgsm1-dev \
libjsoncpp-dev \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev
ADD scripts/build-package-debian.sh /opt/build-package-debian.sh ADD scripts/build-package-debian.sh /opt/build-package-debian.sh
......
...@@ -5,21 +5,54 @@ RUN apt-get update && \ ...@@ -5,21 +5,54 @@ RUN apt-get update && \
# Speed up mk-build-deps # Speed up mk-build-deps
RUN apt-get update && \ RUN apt-get update && \
apt-get install -y autoconf automake cmake libtool libdbus-1-dev \ apt-get install -y -o Acquire::Retires=10 \
libdbus-c++-dev libupnp-dev libgnutls28-dev \ autoconf \
libebook1.2-dev libclutter-gtk-1.0-dev \ automake \
libclutter-1.0-dev libglib2.0-dev libgtk-3-dev \ autopoint \
libnotify-dev qtbase5-dev qttools5-dev \ cmake \
qttools5-dev-tools yasm unbound-anchor git-core \ libtool \
autotools-dev gnome-icon-theme-symbolic gettext \ libdbus-1-dev \
libpulse-dev libsamplerate0-dev libasound2-dev \ libdbus-c++-dev \
libexpat1-dev libpcre3-dev libyaml-cpp-dev \ libupnp-dev \
libboost-dev libsndfile1-dev libsrtp-dev \ libgnutls28-dev \
libxext-dev libxfixes-dev autopoint libspeex-dev \ libebook1.2-dev \
libspeexdsp-dev chrpath uuid-dev libavcodec-dev \ libclutter-gtk-1.0-dev \
libavutil-dev libavformat-dev libswscale-dev \ libclutter-1.0-dev \
libavdevice-dev libopus-dev libudev-dev libticonv-dev \ libglib2.0-dev \
libgsm1-dev libjsoncpp-dev libqrencode-dev libgtk-3-dev \
libnotify-dev \
qtbase5-dev \
qttools5-dev \
qttools5-dev-tools \
yasm \
autotools-dev \
gettext \
libpulse-dev \
libsamplerate0-dev \
libasound2-dev \
libexpat1-dev \
libpcre3-dev \
libyaml-cpp-dev \
libboost-dev \
libsndfile1-dev \
libsrtp-dev \
libxext-dev \
libxfixes-dev \
libspeex-dev \
libspeexdsp-dev \
uuid-dev \
libavcodec-dev \
libavutil-dev \
libavformat-dev \
libswscale-dev \
libavdevice-dev \
libopus-dev \
libudev-dev \
libgsm1-dev \
libjsoncpp-dev \
libnatpmp-dev \
libappindicator3-dev \
libqrencode-dev
ADD scripts/build-package-debian.sh /opt/build-package-debian.sh ADD scripts/build-package-debian.sh /opt/build-package-debian.sh
......
lrc @ 265adc76
Subproject commit 3fc24faf38351b018ebe018a9785d59b76645fd9 Subproject commit 265adc76224a50c147839ba339d48ae6ca414e3f
...@@ -7,6 +7,7 @@ Build-Depends: debhelper (>= 9), ...@@ -7,6 +7,7 @@ Build-Depends: debhelper (>= 9),
automake, automake,
cmake, cmake,
libtool, libtool,
autotools-dev,
# gnome client # gnome client
libebook1.2-dev, libebook1.2-dev,
libclutter-gtk-1.0-dev, libclutter-gtk-1.0-dev,
...@@ -17,19 +18,14 @@ Build-Depends: debhelper (>= 9), ...@@ -17,19 +18,14 @@ Build-Depends: debhelper (>= 9),
qtbase5-dev, qtbase5-dev,
qttools5-dev, qttools5-dev,
qttools5-dev-tools, qttools5-dev-tools,
unbound-anchor,
git-core,
gnome-icon-theme-symbolic,
gettext, gettext,
libqrencode-dev, libqrencode-dev,