Commit a23db0b9 authored by Sébastien Blin's avatar Sébastien Blin

dockerfile: add nasm (necessary for x264)

Change-Id: I90999754457ef714757bb60787c91f89ec9953bd
parent 3f22ac55
......@@ -15,6 +15,7 @@ RUN apt-get update && \
automake \
autopoint \
cmake \
nasm \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
......@@ -29,7 +30,6 @@ RUN apt-get update && \
qttools5-dev \
qttools5-dev-tools \
yasm \
nasm \
autotools-dev \
gettext \
libpulse-dev \
......
......@@ -19,6 +19,7 @@ RUN apt-get update && \
automake \
autopoint \
cmake \
nasm \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
......@@ -33,7 +34,6 @@ RUN apt-get update && \
qttools5-dev \
qttools5-dev-tools \
yasm \
nasm \
autotools-dev \
gettext \
libpulse-dev \
......
......@@ -19,6 +19,7 @@ RUN apt-get update && \
automake \
autopoint \
cmake \
nasm \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
......@@ -33,7 +34,6 @@ RUN apt-get update && \
qttools5-dev \
qttools5-dev-tools \
yasm \
nasm \
autotools-dev \
gettext \
libpulse-dev \
......
......@@ -15,6 +15,7 @@ RUN apt-get update && \
automake \
autopoint \
cmake \
nasm \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
......@@ -29,7 +30,6 @@ RUN apt-get update && \
qttools5-dev \
qttools5-dev-tools \
yasm \
nasm \
autotools-dev \
gettext \
libpulse-dev \
......
......@@ -15,6 +15,7 @@ RUN apt-get update && \
automake \
autopoint \
cmake \
nasm \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
......@@ -29,7 +30,6 @@ RUN apt-get update && \
qttools5-dev \
qttools5-dev-tools \
yasm \
nasm \
autotools-dev \
gettext \
libpulse-dev \
......
......@@ -19,6 +19,7 @@ RUN apt-get update && \
automake \
autopoint \
cmake \
nasm \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
......@@ -33,7 +34,6 @@ RUN apt-get update && \
qttools5-dev \
qttools5-dev-tools \
yasm \
nasm \
autotools-dev \
gettext \
libpulse-dev \
......
......@@ -15,6 +15,7 @@ RUN apt-get update && \
automake \
autopoint \
cmake \
nasm \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
......@@ -29,7 +30,6 @@ RUN apt-get update && \
qttools5-dev \
qttools5-dev-tools \
yasm \
nasm \
autotools-dev \
gettext \
libpulse-dev \
......
......@@ -9,6 +9,7 @@ RUN dnf upgrade -y && \
git \
rpm-build \
tar \
nasm \
make \
autoconf \
automake \
......@@ -27,7 +28,6 @@ RUN dnf upgrade -y && \
libXext-devel \
libXfixes-devel \
yasm \
nasm \
speex-devel \
gsm-devel \
chrpath \
......
......@@ -9,6 +9,7 @@ RUN dnf upgrade -y && \
git \
rpm-build \
tar \
nasm \
make \
autoconf \
automake \
......@@ -27,7 +28,6 @@ RUN dnf upgrade -y && \
libXext-devel \
libXfixes-devel \
yasm \
nasm \
speex-devel \
gsm-devel \
chrpath \
......
......@@ -12,6 +12,7 @@ RUN dnf upgrade -y && \
git \
rpm-build \
tar \
nasm \
make \
autoconf \
automake \
......@@ -31,7 +32,6 @@ RUN dnf upgrade -y && \
libXext-devel \
libXfixes-devel \
yasm \
nasm \
speex-devel \
gsm-devel \
chrpath \
......
......@@ -14,6 +14,7 @@ RUN dnf upgrade -y && \
make \
autoconf \
automake \
nasm \
cmake \
speexdsp-devel \
pulseaudio-libs-devel \
......@@ -30,7 +31,6 @@ RUN dnf upgrade -y && \
libXext-devel \
libXfixes-devel \
yasm \
nasm \
speex-devel \
gsm-devel \
chrpath \
......
......@@ -14,6 +14,7 @@ RUN dnf upgrade -y && \
make \
autoconf \
automake \
nasm \
cmake \
speexdsp-devel \
pulseaudio-libs-devel \
......@@ -30,7 +31,6 @@ RUN dnf upgrade -y && \
libXext-devel \
libXfixes-devel \
yasm \
nasm \
speex-devel \
gsm-devel \
chrpath \
......
......@@ -14,6 +14,7 @@ RUN dnf upgrade -y && \
make \
autoconf \
automake \
nasm \
cmake \
speexdsp-devel \
pulseaudio-libs-devel \
......@@ -30,7 +31,6 @@ RUN dnf upgrade -y && \
libXext-devel \
libXfixes-devel \
yasm \
nasm \
speex-devel \
gsm-devel \
chrpath \
......
......@@ -18,6 +18,7 @@ RUN zypper --non-interactive up -y && \
autoconf \
automake \
cmake \
nasm \
speexdsp-devel \
libpulse-devel \
libcanberra-devel \
......@@ -32,7 +33,6 @@ RUN zypper --non-interactive up -y && \
libXext-devel \
libXfixes-devel \
yasm \
nasm \
speex-devel \
libgsm-devel \
chrpath \
......
......@@ -21,6 +21,7 @@ RUN apt-get update && \
autopoint \
cmake \
libtool \
nasm \
libdbus-1-dev \
libdbus-c++-dev \
libargon2-0-dev \
......@@ -34,7 +35,6 @@ RUN apt-get update && \
qttools5-dev \
qttools5-dev-tools \
yasm \
nasm \
autotools-dev \
gettext \
libpulse-dev \
......
......@@ -21,6 +21,7 @@ RUN dnf upgrade -y && \
autoconf \
automake \
cmake \
nasm \
pulseaudio-libs-devel \
libcanberra-devel \
libcurl-devel \
......
......@@ -86,7 +86,7 @@ ZYPPER_INSTALL_SCRIPT = [
ZYPPER_DEPENDENCIES = [
# build system
'autoconf', 'autoconf-archive', 'automake', 'cmake', 'patch', 'gcc-c++',
'libtool', 'which', 'pandoc',
'libtool', 'which', 'pandoc','nasm',
# contrib dependencies
'curl', 'gzip', 'bzip2',
# daemon
......@@ -115,7 +115,7 @@ DNF_DEPENDENCIES = [
'gtk3-devel', 'clutter-devel', 'clutter-gtk-devel',
'libnotify-devel', 'libappindicator-gtk3-devel', 'patch', 'libva-devel', 'openssl-devel',
'webkitgtk4-devel', 'NetworkManager-libnm-devel', 'libvdpau-devel', 'msgpack-devel', 'libcanberra-devel',
'sqlite-devel', 'openssl-static', 'pandoc'
'sqlite-devel', 'openssl-static', 'pandoc', 'nasm'
]
APT_DEPENDENCIES = [
......@@ -130,7 +130,7 @@ APT_DEPENDENCIES = [
'libudev-dev', 'libyaml-cpp-dev', 'qtbase5-dev', 'libqt5sql5-sqlite', 'sip-tester', 'swig',
'uuid-dev', 'yasm', 'libqrencode-dev', 'libjsoncpp-dev', 'libappindicator3-dev',
'libva-dev', 'libwebkit2gtk-4.0-dev', 'libnm-dev', 'libvdpau-dev', 'libmsgpack-dev', 'libcanberra-gtk3-dev',
'pandoc'
'pandoc', 'nasm'
]
PACMAN_DEPENDENCIES = [
......@@ -140,7 +140,7 @@ PACMAN_DEPENDENCIES = [
'opus', 'pcre', 'libpulse', 'speex', 'speexdsp', 'libtool', 'yaml-cpp',
'qt5-base', 'swig', 'yasm', 'qrencode', 'make', 'patch', 'pkg-config',
'automake', 'libva', 'webkit2gtk', 'libnm', 'libvdpau', 'libcanberra',
'openssl', 'pandoc'
'openssl', 'pandoc', 'nasm'
]
OSX_DEPENDENCIES = [
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment