Commit ac039239 authored by Romain Bertozzi's avatar Romain Bertozzi

OSX : force qt55 version

This patch forces the installation of the qt55 version.
The 5.6+ version makes the compilation fail. See the Tuleap bug for
further information.

Change-Id: I937dcc47ed93156cb4c6fa71ce043a493f6e66a2
Tuleap: #511
parent b21dc578
......@@ -78,7 +78,7 @@ DEBIAN_DEPENDENCIES = [
]
OSX_DEPENDENCIES = [
'autoconf', 'cmake', 'gettext', 'pkg-config', 'qt5',
'autoconf', 'cmake', 'gettext', 'pkg-config', 'homebrew/versions/qt55',
'libtool', 'yasm', 'automake'
]
......@@ -139,7 +139,7 @@ def run_install(args):
if args.global_install:
install_args += ' -g'
if args.distribution == "OSX":
proc= subprocess.Popen("brew --prefix qt5", shell=True, stdout=subprocess.PIPE)
proc= subprocess.Popen("brew --prefix homebrew/versions/qt55", shell=True, stdout=subprocess.PIPE)
qt5dir = proc.stdout.read()
os.environ['CMAKE_PREFIX_PATH'] = str(qt5dir.decode('ascii'))
install_args += " -c client-macosx"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment