Commit c2b821f3 authored by Sébastien Blin's avatar Sébastien Blin Committed by Adrien Béraud

docker: ubuntu 18.04 i386 must use g++8

Change-Id: I5a43f4ca5d0c8e43b3f73cb028aeb38c31b16342
parent 2b996eba
......@@ -10,12 +10,18 @@ RUN apt-get update && \
RUN apt-get clean
RUN apt-get update && \
apt-get install -y -o Acquire::Retries=10 \
g++-8 \
gcc-8 \
cpp-8 \
file \
make \
libc6-dev \
libstdc++-8-dev \
git \
autoconf \
automake \
autopoint \
cmake \
libtool \
libdbus-1-dev \
libdbus-c++-dev \
libgnutls28-dev \
......@@ -65,6 +71,9 @@ RUN apt-get update && \
libssl-dev \
libsndfile1-dev
RUN update-alternatives --install /usr/bin/g++ g++ /usr/bin/g++-8 50
RUN update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-8 50
ADD scripts/build-package-debian.sh /opt/build-package-debian.sh
CMD /opt/build-package-debian.sh
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment