Commit 1bec0fe3 authored by Alexandre Savard's avatar Alexandre Savard
Browse files

[#4354] Make celt a direct dependency on launchpad opensuse build service

parent 5b4fda62
......@@ -2,13 +2,13 @@ Source: sflphone-common
Maintainer: SavoirFaireLinux Inc <julien.bonjean@savoirfairelinux.com>
Section: gnome
Priority: optional
Build-Depends: debhelper, libgcc1 , autoconf, automake, libpulse-dev, libsamplerate0-dev, libcommoncpp2-dev, libccrtp-dev, libgsm1-dev, libspeex-dev, libtool, libdbus-1-dev, libasound2-dev, libspeexdsp-dev, uuid-dev, libexpat1-dev, libzrtpcpp-dev, libssl-dev, libpcre3-dev, libyaml-dev
Build-Depends: debhelper, libgcc1 , autoconf, automake, libpulse-dev, libsamplerate0-dev, libcommoncpp2-dev, libccrtp-dev, libgsm1-dev, libspeex-dev, libtool, libdbus-1-dev, libasound2-dev, libspeexdsp-dev, uuid-dev, libexpat1-dev, libzrtpcpp-dev, libssl-dev, libpcre3-dev, libyaml-dev, libcelt-dev
Standards-Version: 3.7.3
Package: sflphone-common
Priority: optional
Architecture: any
Depends: libsamplerate0, libexpat1 , libc6, libccgnu2-1.7-0, libgsm1, libspeex1, libdbus-1-3, libasound2, libpulse0, libccrtp1-1.7-0, libspeexdsp1, libzrtpcpp-1.4-0, libssl0.9.8, libpcre3, libyaml-0-2
Depends: libsamplerate0, libexpat1 , libc6, libccgnu2-1.7-0, libgsm1, libspeex1, libdbus-1-3, libasound2, libpulse0, libccrtp1-1.7-0, libspeexdsp1, libzrtpcpp-1.4-0, libssl0.9.8, libpcre3, libyaml-0-2, libcelt0-0
Replaces: sflphone
Conflicts: sflphone
Homepage: http://www.sflphone.org
......
......@@ -2,13 +2,13 @@ Source: sflphone-common
Maintainer: SavoirFaireLinux Inc <julien.bonjean@savoirfairelinux.com>
Section: gnome
Priority: optional
Build-Depends: debhelper, libgcc1 , autoconf, automake, libpulse-dev, libsamplerate0-dev, libcommoncpp2-dev, libccrtp-dev, libgsm1-dev, libspeex-dev, libtool, libdbus-1-dev, libasound2-dev, libspeexdsp-dev, uuid-dev, libexpat1-dev, libzrtpcpp-dev, libssl-dev, libpcre3-dev, libyaml-dev
Build-Depends: debhelper, libgcc1 , autoconf, automake, libpulse-dev, libsamplerate0-dev, libcommoncpp2-dev, libccrtp-dev, libgsm1-dev, libspeex-dev, libtool, libdbus-1-dev, libasound2-dev, libspeexdsp-dev, uuid-dev, libexpat1-dev, libzrtpcpp-dev, libssl-dev, libpcre3-dev, libyaml-dev, libcelt-dev
Standards-Version: 3.7.3
Package: sflphone-common
Priority: optional
Architecture: any
Depends: libsamplerate0, libexpat1 , libc6, libccgnu2-1.7-0, libgsm1, libspeex1, libdbus-1-3, libasound2, libpulse0, libccrtp1-1.7-0, libspeexdsp1, libzrtpcpp-1.4-0, libssl0.9.8, libpcre3, libyaml-0-2
Depends: libsamplerate0, libexpat1 , libc6, libccgnu2-1.7-0, libgsm1, libspeex1, libdbus-1-3, libasound2, libpulse0, libccrtp1-1.7-0, libspeexdsp1, libzrtpcpp-1.4-0, libssl0.9.8, libpcre3, libyaml-0-2, libcelt0-0
Replaces: sflphone
Conflicts: sflphone
Homepage: http://www.sflphone.org
......
......@@ -2,13 +2,13 @@ Source: sflphone-common
Maintainer: SavoirFaireLinux Inc <julien.bonjean@savoirfairelinux.com>
Section: gnome
Priority: optional
Build-Depends: debhelper, libgcc1 , autoconf, automake, libpulse-dev, libsamplerate0-dev, libcommoncpp2-dev, libccrtp-dev, libgsm1-dev, libspeex-dev, libtool, libdbus-1-dev, libasound2-dev, libspeexdsp-dev, uuid-dev, libexpat1-dev, libzrtpcpp-dev, libssl-dev, libpcre3-dev, libyaml-dev
Build-Depends: debhelper, libgcc1 , autoconf, automake, libpulse-dev, libsamplerate0-dev, libcommoncpp2-dev, libccrtp-dev, libgsm1-dev, libspeex-dev, libtool, libdbus-1-dev, libasound2-dev, libspeexdsp-dev, uuid-dev, libexpat1-dev, libzrtpcpp-dev, libssl-dev, libpcre3-dev, libyaml-dev, libcelt-dev
Standards-Version: 3.7.3
Package: sflphone-common
Priority: optional
Architecture: any
Depends: libsamplerate0, libexpat1 , libc6, libccgnu2-1.7-0, libgsm1, libspeex1, libdbus-1-3, libasound2, libpulse0, libccrtp1-1.7-0, libspeexdsp1, libzrtpcpp-1.4-0, libssl0.9.8, libpcre3, libyaml-0-2
Depends: libsamplerate0, libexpat1 , libc6, libccgnu2-1.7-0, libgsm1, libspeex1, libdbus-1-3, libasound2, libpulse0, libccrtp1-1.7-0, libspeexdsp1, libzrtpcpp-1.4-0, libssl0.9.8, libpcre3, libyaml-0-2, libcelt0-0
Replaces: sflphone
Conflicts: sflphone
Homepage: http://www.sflphone.org
......
......@@ -27,6 +27,8 @@ BuildRequires: expat
BuildRequires: libzrtpcpp-devel
BuildRequires: commoncpp2-devel
BuildRequires: libsamplerate-devel
BuildRequires: libyaml-devel
BuildRequires: libcelt-devel
%if %{defined suse_version}
BuildRequires: libpulse-devel
......@@ -40,7 +42,6 @@ BuildRequires: libexpat0
BuildRequires: alsa-devel
BuildRequires: dbus-1-devel
BuildRequires: pcre-devel
BuildRequires: libyaml-devel
%endif
%if %{defined fedora_version}
......@@ -55,12 +56,13 @@ BuildRequires: gsm-devel
BuildRequires: alsa-lib-devel
BuildRequires: dbus-devel
BuildRequires: pcre-devel
BuildRequires: libyaml-devel
%endif
Requires: libsamplerate
Requires: commoncpp2
Requires: dbus-1
Requires: libyaml
Requires: libcelt
%if %{defined suse_version}
Requires: libgsm1
......@@ -69,7 +71,6 @@ Requires: libspeex
Requires: libasound2
Requires: libpulse0
Requires: libccrtp1
Requires: libyaml
%endif
%if %{defined fedora_version}
......@@ -81,7 +82,6 @@ Requires: alsa-lib
Requires: pulseaudio-libs
Requires: ccrtp
Requires: libzrtpcpp
Requires: libyaml
%endif
Conflicts: sflphone
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment