Commit c4df2f32 authored by Sébastien Blin's avatar Sébastien Blin
Browse files

packaging: add fedora 34

Change-Id: I0636da7d2b26eb75a6f8f3a37a2c92f1fd05fdfd
parent 989c02ff
FROM fedora:34
RUN dnf clean all
RUN dnf install -y dnf-command\(builddep\) rpmdevtools
RUN dnf clean all
RUN dnf upgrade -y && \
dnf install -y mesa-libgbm-devel mesa-dri-drivers && \
dnf install -y libinput-devel && \
dnf install -y \
git \
rpm-build \
tar \
make \
autoconf \
automake \
nasm \
cmake \
speexdsp-devel \
pulseaudio-libs-devel \
libcanberra-devel \
libcurl-devel \
libtool \
dbus-devel \
expat-devel \
pcre-devel \
yaml-cpp-devel \
boost-devel \
dbus-c++-devel \
dbus-devel \
libXext-devel \
libXfixes-devel \
yasm \
speex-devel \
gsm-devel \
chrpath \
check \
astyle \
uuid-c++-devel \
gettext-devel \
gcc-c++ \
which \
alsa-lib-devel \
systemd-devel \
libuuid-devel \
uuid-devel \
gnutls-devel \
nettle-devel \
opus-devel \
patch \
jsoncpp-devel \
libnatpmp-devel \
webkitgtk4-devel \
cryptopp-devel \
libva-devel \
libvdpau-devel \
msgpack-devel \
NetworkManager-libnm-devel \
openssl-devel \
openssl-static \
clutter-devel \
clutter-gtk-devel \
libappindicator-gtk3-devel \
libnotify-devel \
libupnp-devel \
qrencode-devel \
qt5-qtbase-devel \
qt5-qttools-devel \
sqlite-devel
ADD scripts/build-package-fedora.sh /opt/build-package-fedora.sh
CMD /opt/build-package-fedora.sh
...@@ -78,7 +78,7 @@ is_distribution_supported() { ...@@ -78,7 +78,7 @@ is_distribution_supported() {
. /etc/os-release . /etc/os-release
case ${ID}_${VERSION_ID%.*} in case ${ID}_${VERSION_ID%.*} in
rhel_8|fedora_32|fedora_33) rhel_8|fedora_32|fedora_33|fedora_34)
return 0;; return 0;;
esac esac
......
...@@ -98,6 +98,8 @@ enabled=1' ...@@ -98,6 +98,8 @@ enabled=1'
ENDTAG="fedora_32" ENDTAG="fedora_32"
elif [ "${PLATFORM_ID}" = "platform:f33" ] || [ "${ID}_${VERSION_ID}" = "fedora_33" ]; then elif [ "${PLATFORM_ID}" = "platform:f33" ] || [ "${ID}_${VERSION_ID}" = "fedora_33" ]; then
ENDTAG="fedora_33" ENDTAG="fedora_33"
elif [ "${PLATFORM_ID}" = "platform:f34" ] || [ "${ID}_${VERSION_ID}" = "fedora_34" ]; then
ENDTAG="fedora_34"
else else
# Distribution is not supported. Don't provide automatic updates. # Distribution is not supported. Don't provide automatic updates.
CAN_ADD_YUM_SOURCE=false CAN_ADD_YUM_SOURCE=false
......
...@@ -36,7 +36,7 @@ cp /opt/ring-project-ro/jami_*.tar.gz /root/rpmbuild/SOURCES ...@@ -36,7 +36,7 @@ cp /opt/ring-project-ro/jami_*.tar.gz /root/rpmbuild/SOURCES
# Set the version # Set the version
sed -i "s/RELEASE_VERSION/${RELEASE_VERSION}/g" *.spec sed -i "s/RELEASE_VERSION/${RELEASE_VERSION}/g" *.spec
if [ ${DISTRIBUTION} == "fedora_32" ] || [ ${DISTRIBUTION} == "fedora_33" ]; then if [ ${DISTRIBUTION} == "fedora_32" ] || [ ${DISTRIBUTION} == "fedora_33" ] || [ ${DISTRIBUTION} == "fedora_34" ]; then
# Remove Obsoletes for Fedora 32, as we don't publish "ring" # Remove Obsoletes for Fedora 32, as we don't publish "ring"
sed -i '/^Obsoletes:/d' *.spec sed -i '/^Obsoletes:/d' *.spec
sed -i '/^Provides:/d' *.spec sed -i '/^Provides:/d' *.spec
......
...@@ -258,6 +258,12 @@ def run_generate_all(parsed_args): ...@@ -258,6 +258,12 @@ def run_generate_all(parsed_args):
"output_file": ".packages-built", "output_file": ".packages-built",
"options": RPM_BASED_SYSTEMS_DOCKER_RUN_OPTIONS "options": RPM_BASED_SYSTEMS_DOCKER_RUN_OPTIONS
}, },
{
"distribution": "fedora_34",
"debian_packaging_override": "",
"output_file": ".packages-built",
"options": RPM_BASED_SYSTEMS_DOCKER_RUN_OPTIONS
},
{ {
"distribution": "rhel_8", "distribution": "rhel_8",
"debian_packaging_override": "", "debian_packaging_override": "",
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment