Commit 1ffc7fc3 authored by Stepan Salenikovich's avatar Stepan Salenikovich Committed by Guillaume Roguez

make-ring: remove webkit2gtk-3.0 from dependencies

Since ring does not compile on Ubuntu 14.04, there is no point in
keeping this dependency. This will also prevent the make-ring
script from failing on Ubuntu 16.10, where --ignore-missing no longer
seems to work to prevent apt from failing when we try to install
a non-existant package.

Change-Id: I21ae61786aa1019b8b644115ff2c1cab54c566fe
Reviewed-by: Guillaume Roguez's avatarGuillaume Roguez <guillaume.roguez@savoirfairelinux.com>
parent 1846722d
......@@ -34,7 +34,7 @@ SUSE_BASED_DISTROS = [
APT_INSTALL_SCRIPT = [
'apt-get update',
'apt-get install -y %(packages)s --ignore-missing'
'apt-get install -y %(packages)s'
]
BREW_UNLINK_SCRIPT = [
......@@ -119,7 +119,7 @@ UBUNTU_DEPENDENCIES = [
'libudev-dev', 'libupnp-dev', 'libyaml-cpp-dev', 'qtbase5-dev', 'sip-tester', 'swig',
'uuid-dev', 'yasm', 'libqrencode-dev', 'libjsoncpp-dev', 'libappindicator3-dev',
'libva-dev', 'libnm-glib-dev',
'libwebkit2gtk-4.0-dev', 'libwebkit2gtk-3.0-dev' # we prefer 4.0, but 3.0 will work, we use --ignore-missing so apt-get doesn't fail
'libwebkit2gtk-4.0-dev'
]
DEBIAN_DEPENDENCIES = [
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment